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Agisoft Structure-from-Motion Protocols 
Anna Roser, Valorie Marie, Peter Olsoy, Trevor Caughlin – Boise State 

Donna Delparte – Idaho State 

Step 1: Start > Agisoft > Agisoft Metashape Professional 

 

Workflow > Add Photos 

 

 

SAVE THE PROJECT. The project name should include the site name and date of collection.  

 

Step 2: Check the Reference Settings and Camera Lens Calibration 
Reference > Settings 

 

Check that the Camera Reference and Marker Reference Boxes are checked if you have GPS data for both. Also 

check that the accuracy is correct. (see image below) 
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Update the setting for the Mavic drone rolling shutter.  

Tools >> Camera calibration >> Check 'Enable rolling shutter compensation' for the entire processing routine 

 

SAVE THE PROJECT 

Step 3: Load in Ground Control markers  
Use the same folder icon in the reference toolbar. The Rotation section should be unchecked. 



3 
 

 

 

Check the lat/long/elv of photos and markers. Does everything line up and look correct in the model space? If 

the elevation is incorrect (often occurs when using DJI mavic or phantom) this is the time to make an altitude 

correction.  
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Step 4: Workflow > Align Photos 
Match your options to those shown below. This will be the first of several alignments. This first alignment is to 

get the general locations of the photos. Press ‘OK’ once your alignment tab matches the screenshot below.  

 

 

SAVE THE PROJECT 

Step 5: Place Markers. 
First, turn on ‘Refine Markers’. This will allow Agisoft to place the flags on the target centers without you having 

to place every single one. Go to Tools-> Markers -> Refine Markers. Click to add the check mark – if there’s 

already a check mark, then it’s already on.  
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Right click on flag 1 > Filter photos by markers 

 

 

Place 5-7 markers on the center of the ground control points (GCP). Click and drag flags to move. Move through 

these flags slowly so that Agisoft can update and place the blue flags on target centers. Once the flags have 

auto-placed, page through them to make sure they look centered and look for white flags. White flags are ones 

that you still need to place.  

TIP: on your keyboard, use “PgUp” and “PgDown” keys to quickly switch between photos without moving your 

mouse! 

TIP: don’t chase errors with marker placement—just try to be consistent then update. Don’t shimmy the flags 

around. Ignore error until you’ve accurately placed flags 

 

 

(Flag should turn green when repositioned, or blue once the auto placement has occurred.) 
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When you have completed all the markers for three targets, in the Reference pane click Update and then 

Optimize.  

 

 

Once you have completed the placement of three markers, return to update and optimize for every subsequent 

marker! 

 

Now, return to the top of step Five and place the markers for another target. Repeat this 

process until for all of the targets and there are no more white flags – all flags must be 

green or blue. Remember to save frequently!  

 

Before you move to Step 6, recheck all of your markers with Filter by Marker – sometimes after all of the Update 

and Optimize, Agisoft will identify new photos that have a flag that needs to be placed. Look for any new white 

flags for each marker and place them.  

Do a final Update and Optimize and Save.  
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Scale Bars 
If you have a board that looks like this: 

 

You’ll treat it as two normal GCP points and a scale bar. Complete the marker placement for all of the other 

GCPs in the scene before pinning the GCPs on the scale board.  

If only one end of the scale bar has a GPS point, create a marker for the other end but leave it unchecked and 

clear the lat/long data.  

In the Reference pane, highlight the two GCP points that represent the ends of the scale bar, right click and 

choose “create scale bar”. 

 

The scale bar will appear below the markers in the Reference pane. In the Distance section, add in 1.0m (this will 

depend on the scale so check with whomever collected the data).  

 

Place the two markers as you would any other marker.  
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Step 6: Export Camera Locations 
Click the Export Reference button.  

 

 

In the ‘agisoft’ folder for your current project, name the file “camera_locations_update_v1.txt” and Click ‘Save”.  

 

For the cameras, we’re going to save the ‘Rotation’ and ‘estimated values’. The precision will be 6 and we’ll use 

a ‘Comma’ as the Delimiter (see below).  
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Step 7: Import Estimated Camera Locations 

 

Select the .txt file that you just created. You’ll need to adjust the numbers to the correct columns and start the 

import at Row 3. You’ll also bring in the Yaw, Pitch, and Roll that were estimated. (see below). 

 

SAVE 
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Step 8: Align Photos Again on High Quality 
Run Alignment again with parameters that match the screen below*. We’re forcing Agisoft to use the estimated 

locations as the source for this version.  

*Depending on the site, the key point limit can go higher than this.  
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A. Check placement error for the photos and markers: 

  

Marker errors should be < ~.02 m ( < 2 cm). 

Camera errors should be less than 1m.  

Scroll to the bottom of the camera and marker list, in the Reference pane, to view your total error. 

***If your cameras or markers are not below the threshold for error, go back to Step 6 and work back to this 

point through all of the steps.  

 Step 9: Gradual Selection = Clean the Sparse Cloud 
In order to reduce the errors in the adjustment in order to improve the geometry of the overall model.  

Three steps are used and repeated as necessary to reduce the errors as much as possible: 

A. Reconstruction Uncertainty  

removing bad points due to poor geometry  

B. Projection Accuracy  

removing bad points due to pixel matching errors 

C. Reprojection Error  

removing bad points due to pixel residual errors 

Make sure the Model tab is active, then go Model > Gradual Selection  
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For each step you’ll move the slider and watch the model to see where points are selected (in pink). Do 

not select more than 5,000-10,000 points per step. If points that are the tops of sagebrush or plants or 

objects of interest are getting selected, then back off the slider until those points are unselected.  

Once the points are selected, Press Delete. Click Update and Optimize. Repeat for 9 A, B, and C.  

 

Step 10: Build Dense Cloud 
Save your Project. 

Resize region bounding box before building dense cloud. Using all three of the tools shown below, reduce the 

box to the size of the study area. This will save a lot of processing time and result in data products that don’t 

take up excess space. 

 

Workflow -> Build Dense Cloud. Copy the settings below and then Press OK. This will take several hours! Ultra 

high quality may not be the best option. High quality may be preferable to reduce noise. If dense cloud is too 

noisy in canopy -> run on High. 
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Step 11: Clean Dense Cloud 
Save Project.  

When we clean the dense cloud, we’re looking for erroneous points and points that have low location 

confidence. We want to remove those points at this step so that when we build products that are based on the 

dense cloud, we’re using the best model possible.  

Switch to Model View so that you can see the dense cloud and manipulated it. 

 

Next, change the display of the dense cloud. On the top icon menu, click the icon with nine dots and select 

“Dense Cloud Confidence.” 

 

Your point cloud is now displaying a level of confidence for each point, rather than RGB colors. Red points are 

the least confident and blue and most confident. You’ll probably notice that there are more red, low confidence, 

points around the edges of the site and objects that are more difficult to reconstruct, like trees and some 

shrubs.  

To remove the most erroneous points, we will filter the cloud to show the lowest confidence.  

Tools-> Dense Cloud -> Filter by Confidence (see screen shot) 
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Change the Max to “1” and press OK. 

 

The remaining point cloud is made up of points that have a confidence of 1.  

A. Manually delete points  

Use the manual selection tool  to draw around points that you’d like to select and delete.  

Check out the Tips section at the bottom of this document to see the key short cuts to move the cloud around 

while you’re cleaning.  

For example, we want to select points that are randomly floating in the air. In some instances, we may delete all 

the points with a confidence of 1, but that will depend on the site.  

 

Step 12: Batch Process to create products 
Run a Batch Process. Workflow > Batch Process 

Click “Add” for each step. Match all of your steps to the screen shots for each.  
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A. Build DEM  
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B. Build Orthomosaic  

 

 

 

 

 

 

 

 

 

 

 



17 
 

 

Save after each step!   

 

The batch process will take several hours to run at least. As a courtesy to others using the shared computer, 

please note to other users that the computer will be running an intensive program for a while.  

Step 13: Generate Report  
Once the batch process is complete, a good way to review all of your work is to generate a report.  

File > Export > Generate Report 

Name the file after the project and save the PDF in the Products folder.  

In Agisoft, look at the ortho, look for blurry images -> find and remove those photos. Just regenerate ortho. 

Can’t disable too many photos because it’ll result in holes. 

Also, look at DEM for crumbles or holes. If it’s very rough or noisy. If it should be flat and there’s surface noise --

there may be some parameter changes needed.  

Step 14: Export Products 
In this step we’ll export an orthomosaic, dsm, and point cloud.  

A. Export Ortho 
In Workspace, right click on Orthomosaic -> Export Ortho -> Export JPEG/TIFF/PNG

 

Under ‘Coordinate System’ choose WGS 84 / UTM zone 12N*. The easiest way to find this system is to click 

the coordinate drop down menu and click ‘More…’ . In the Filter type ‘32612’ which is the numeric code for 

the coordinate system.  

*the coordinate system depends on where the flight was and what data you need to match.  

On the ortho export widow, you should only have to change three inputs (highlighted below).  
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Click Export.  

Choose the file location to save the product. If you don’t already have one, make a folder called ‘products’ 

for your site.  

Name your site very specifically so it’s easy to identify later. Use this template: 

 “cr_2021_june_site[your site number]_ortho_wgs84utm12” 

Here’s my example for site 1: 

 

Click save. 

B. Export DSM 
In Workspace, right click on DEM -> Export DEM -> Export JPEG/TIFF/PNG 

Under ‘Coordinate System’ choose WGS 84 / UTM zone 12N. The easiest way to find this system is to click 

the coordinate drop down menu and click ‘More…’ . In the Filter type ‘32612’ which is the numeric code for 

the coordinate system.  
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On the export widow, you should only have to change one input, the coordinate system.  

Click Export.  

Save the DSM in the same location as the ortho.  

Name your site very specifically so it’s easy to identify later. Make sure you update the name to note that 

it’s a dsm, not an ortho. Use this template: 

 “cr_2021_june_site[your site number]_dsm_wgs84utm12” 

Click save. 

C. Export Point Cloud 
In Workspace, right click on dense cloud -> Export Dense Cloud  

Save the point cloud in the same location as the ortho and DSM.  

Name your site very specifically so it’s easy to identify later. Make sure you update the name to note that 

it’s a point cloud. Also make sure you save as type “ASPRS LAS”. Use this template: 

 “cr_2021_june_site[your site number]_pointcloud_wgs84utm12.las” 

 

Click save. 

 

Under ‘Coordinate System’ choose WGS 84 / UTM zone 12N. The easiest way to find this system is to click 

the coordinate drop down menu and click ‘More…’ . In the Filter type ‘32612’ which is the numeric code for 

the coordinate system.  

On the export widow, you should only have to change one input, the coordinate system.  
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Click Export.  

 

 

Troubleshooting and Tips 

Run Image Quality Check 
This can help you to identify cameras that are low quality and you can consider removing these from the project.  

In the “Photos” tab, select all of the images, right click and select “Estimate Image Quality…”. Pick “All Cameras” 

and click Ok.  
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Once the Quality Estimate is done, review the outputs in the new Photos column. Click the column name Quality 

to switch the sorting. If there are any photos with a Quality rating of less then .65, highlight and delete those 

photos. Then run Update and Optimize – and SAVE! 

 



22 
 

Tip: Model View Shortcut Keys 

 

 


